Home Forums Solution suite Ryu SDN starter kit Problems with topology viewer

This topic contains 3 replies, has 3 voices, and was last updated by  Iam Will 1 year, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1124

    Abbadon
    Participant

    Hi!

    I’m trying to visualize my SDN topology with your SDN starter kit.
    It seems like the installation worked and I’m also able to run the sh script (run_sdnhub_apps.sh).

    But the topology viewer doesn’t work as expected. I set up a mininet with one switch and three hosts with following command:
    sudo mn --topo single,3 --mac --controller remote --switch ovsk

    After pinging all hosts (mininet command “pingall”) the topology is displayed like this:
    Topology viewer

    The hosts are not displayed and it is not possible to scroll down where the hosts might be. It looks like there is also only one host displayed instead of three.
    Flows and Ports are displayed correctly. IPs of all hosts are listed under “Load balancer”

    The json answers contain all three hosts.

    I also tried the VM given on the starter kit website, but it gives the same result.

    Thanks for any advice.

    • This topic was modified 2 years, 4 months ago by  Abbadon.
    • This topic was modified 2 years, 4 months ago by  Abbadon.
    #1127

    Abbadon
    Participant

    UPDATE: It looks like there is a type error in JavaScript:
    TypeError: Argument 1 of SVGPathElement.getPointAtLength is not a finite floating-point value.1 joint.all.min.js:19:30162

    Afterwards I get more type errors in the hostCleanup-function:
    TypeError: value.link is undefined1 topology.js:96:8

    #1295

    Gabriel Paues
    Participant

    Hello!

    I’m having the same problem using Chrome. Did you find any solution to this?

    BR,

    Gabriel Paues

    #1299

    Iam Will
    Participant

    Not know the root cause, but specific version google-chrome do show it well, you can try the version of 39.0.2171.95 ´╝łmaybe version 39 is all you need).

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Login with: